SS-Libev和熵

shadowsocks作为扶墙利器经过GFW的封杀和墙国的打压,一些作者已经停止维护开发,有的删除了github上的项目。目前SS仍然使用最多的匿名VPN之一,但shadowsocks各个版本中只有SS-libev还保持着更新。

使用原生的代码即可安装SS-libev,当然也可以使用一键脚本,但有人说一键脚本容易被识别被封。 github代码在这。 按照readme可以轻松安装使用。

但是,今天说的是,本人遇到的一个问题,就是SS-Libev已经作为系统服务安装成功,可以不能代理不能连接。输入 systemctl status shadowsocks-libev 查看,

提示 This system doesn’t provide enough entropy to quickly generate high-quality random numbers
Installing the rng-utils/rng-tools or haveged packages may help.
On virtualized Linux environments, also consider using virtio-rng.
The service will not start until enough entropy has been collected.

这里的entropy是“熵”的意思,大致意思是说该服务需要一定的系统“蓄能”,而需要安装rng-tools才可以满足启动的条件。

那么

apt-get update
apt-get install rng-tools
同时 修改 /etc/default/rng-tools 添加 HRNGDEVICE=/dev/urandom

再重启服务器,一般ss-libev就可以成功启动使用了。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据