php无法更新

linux的开源系统包括debian和ubuntu基本上两年就更新一个版本,之后会逐步停止更新,服务器用的LTS(长久支持版本)会维持数年后被关闭更新,但是与之相应的程序比如php,由于需要第三方提供更新,就可能无法维持长久的更新。

debian version code name

作为第三方php程序托管,deb.sury.org 已经删除了一些php更新源,目前来看只保留了debian10的更新,旧的和新的版本(debian11)均无法获取php安装和维护了,这意味着通过apt update将获得错误的提示信息而无法安装和更新php。debian9系统自带的安装源只能够默认安装php7,无法安装php8。

对于ubuntu ,有另外一种安装和维护php的模式,就是PPA 和apt类似,可更新源可以查看

总结一点就是,时刻保持不停的更新和备份

发表回复

您的电子邮箱地址不会被公开。

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据